Cannot find ContentTypeReader

Topics: Developer Forum, User Forum
Mar 15, 2007 at 8:35 AM
I tried to get your drawf demo working and discovered that the dll in the release tab is broken or corrupt so I d/l the source to compile the animationcomponent dll. I added the reference to my demo project and followed the second step of the tutorial but got the following error message when it tried to load the dwarf model.

Error loading "content\model\dwarfmodel". Cannot find ContentTypeReader Xclna.Xna.Animation.Content.AnimationReader, Xclna.Xna.Animationx86, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null.

I cannot reason, why the dll cannot find the AnimationReader Class when it is obviously in the source code.

I have not idea what's wrong and some help would be much appreciated.
Coordinator
Mar 15, 2007 at 7:49 PM
Edited Mar 15, 2007 at 7:50 PM
We'll, the dll in the release tab works for the five computers I tried it on. I do not think it is corrupt. Can you explain what error you are getting when trying to use the DLLs?

The problem you are getting with compiling the source is that you need to change the assembly versions to the correct values in AssemblyInfo.cs OR project properties tab -> Application -> Assembly info. The current version is 1.0.1.0
Mar 16, 2007 at 1:32 AM
the version number might have been when I was trying to messed around with the settings to try to get it to work.

It wasn't working(got the same error message except with version 1.0.1.0) when the version was set to 1.0.1.0 but i can double check.

As for the DLL when I tried to make a reference to it in my project and the IDE said that the DLL wasn't a DLL and to make sure it was. Let me see if the lastest binary works else I'll post the error msg.

Thanks
Mar 16, 2007 at 8:17 AM
I redownloaded the release and found the correct dlls. The only i originally used only had an AnimationComponent file in it, which now i think of it is very wierd. And your current release dlls work.

However, i guess I still can't get the source code to generate the correct dlls since only one is being generated.


Anyway, would it be possible for you to post up or create a document that gives instructs on how to correctly compile the source?

Anyway, Thanks for all your help.
Coordinator
Mar 16, 2007 at 12:03 PM
The FAQ on the front page provides a link to step by step instructions on how to compile the source.