Biped object is moving while the model NOT

Oct 24, 2009 at 1:31 PM

Hi...

I use 3ds Max 8 to animate the leg of the famous model (The Baby-you know the dancing baby) I just made the leg move for a test using a bipe..it went ok and the baby moves...

ok now when exporting to X file...and loading it in XNA 3 using the animation component..and making the animation run, the bipe (which I did not hide it) moves as expected while the baby model is static not moving

why is that?????

I use Pand Directx exporter....

I read most of topics in this forum about animation and no topic is like this case....

note: I am not choosing "Bones" when exporting because if I chose "Bones" choice the XNA3 can not read the file and give me the error:

"an Item with the same key has already been added"

and when I uncheck the "Bones" choice ..the bipe moves while object does not....

I tried to use both Physique and skin animation...they both give the same result...

 

Please help me in this...it is a college project..and this seems the only problem which if I solve it ..my project will be done in a minute...

Thanks..and any source code if you want I can upload it...

 

Oct 26, 2009 at 1:00 AM

Sigh...

Unfortunately this project is long dead - I have no idea why your using it.

I like to try to help with what problems I can, but this one is a little beyond me. It sounds like a problem with your model, and I don't have 3DS Max :D

Also, almost no one who probably would know comes around this forum anymore.

 

I suggest you take a look at some of the other libraries (e.g. XNAnimation and KiloWatt).

Just in case it is a coding problem, could you post it?

 

YellPika

Jan 9, 2010 at 3:22 AM

With 3ds Max & animated models I suggest:

Biped + skin modifier

be careful, 1st apply the UV modifier & IN THE END do the skinning.
DO NOT HIDE BONES, DO NOT HIDE BIPPED nor helpers.
Export as FBX (u can even embed textures with the exporter, it comes included with 3DsMax).

This worked for me with 3DsMax 9. I found it better to work with FBX when the model is animated & with X when it isn't.

Hope this help :)
Good luck!

Feb 26, 2010 at 4:25 AM
Edited Feb 26, 2010 at 4:26 AM

OH MY GOD, OH MY GOD!!!!!!!
I've just run thru your same, exact problem!!!!!!!

It's a damn bug in the library!!!!!!!!!!!
I spent like 3 or 4 hours! It's nonsense!!!!!!!!

It's as easy as...:
In XNA, select the model -> Properties -> Content Importer -> "X File - XNA Framework"

That's it...
U have to export with "bones" on in 3DsMax (Panda). I updated the last Panda (i'm using 3DsMax 9, so the last panda for this version).

-apply "Skin modifier". Paint weights in every bone.
-Leave only "Skin" & "Editable mesh" in the stack. Skin must always be in the top (so first UVW, Smooth, etc). When u are done, "Collapse to" all that's below "Skin" (DO NOT COLLAPSE "SKIN"!!!)
-Do not hide bones
-In Panda, enable "bones", "mesh definition", "materials", "include animations", "geometric", "dummy", "mesh normals", "mapping coordinates", "vertex colors". Be sure to select "Position, scale & rotate", "sub frame hierarchy", & "left handed axis" (careful in this last one as sometimes it doesn't pay attention to your choice: uncheck it & check it again -it kinda doesn't internally update the checkbox state if u just click it once).

Sorry for bringing the solution kinda late... but well, i hope it's useful to someone!
Good luck, & feel free to contact me!

Synth