Having trouble loading a simple cube that is animated (.x)

Topics: User Forum
Aug 5, 2007 at 11:37 PM
Hey Guys,
I went through the tutorial on this library fine. When i try to load a simple cube that has been animated i get this error :

Error 1 Building content threw Exception: Failed to parse Microsoft.Xna.Framework.Matrix at token number 8214
value: ;
Surrounding tokens:
XSkinMeshHeader{4;4;4;}SkinWeights{"Root";0;*;;-0.005102,0.999987,-0.000067,0.000000,0.999901,0.005102,0.013106,
at Xclna.Xna.Animation.Content.XFileTokenizer.Throw(Type type)
at Xclna.Xna.Animation.Content.XFileTokenizer.NextMatrix()
at Xclna.Xna.Animation.Content.XModelImporter.XMeshImporter.ImportSkinWeights()
at Xclna.Xna.Animation.Content.XModelImporter.XMeshImporter.ImportMesh()
at Xclna.Xna.Animation.Content.XModelImporter.ImportNode()
at Xclna.Xna.Animation.Content.XModelImporter.ImportRoot()
at Xclna.Xna.Animation.Content.XModelImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetDirectly(BuildItem item, String importerName)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAndLoadAsset(BuildItem item, BuildItem requestingItem)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetViaCache(BuildItem item, String importerName)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()
at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, TimestampCache timestampCache, ITaskItem[] sourceAssets, String[]& outputContent, String[]& rebuiltContent, String[]& intermediates, Dictionary`2& dependencyTimestamps, KeyValuePair`2[]& warnings) C:\Documents and Settings\Gokul\My Documents\Visual Studio 2005\Projects\WindowsGame4\WindowsGame4\Models\bouncybox.x WindowsGame4


this file loaded properly when only the root bone was exported from maya, but when the whole model was exported, i got that error. The model seems to load fine when it is not using the Animation Library Content Importer, but that is no good since we want the animations.

Any Ideas?

Thanks,
Gokz